How to Fail at Everything Internet – A Comcast Tale

This post represents the culmination of over a month of testing, hours or phone calls, twitter conversations, installations, and e-mails all in trying to work with Comcast to resolve an issue with my newly installed Gigabit Internet. It is incredulous to think any company would make it this difficult for someone to give them money each month! It is not 100% narrative, and at times could seem scattered, but I have done my best to document the incredulous experience which I can only describe as being foul and shameful. If Comcast has been trying to improve their abysmal customer service, they are failing. This is an example of such a failure…

Technicolor TC4400 DOCSIS 3.1 Cable Modem

For years we had fiber from our local/rural phone company. Unfortunately, they went thru a tumultuous time a few months ago when their GPON cards began failing left & right, bringing my connection down for days on end. I bit the bullet and bought a DOCSIS 3.0 Cable Modem from Amazon and self activated 150 meg XFINITY Internet. Soon after (probably less than 2 weeks) I found XFINITY Gigabit was available and ordered it for install.  We had XFINITY Gigabit installed on June 14. It is a Coax service, and their technician provided us with a Technicolor TC4400 DOCSIS 3.1 Modem.

It is worth noting, the Technicolor modem (at least the ones from Comcast) do not show the event log page, you can’t see what’s going on at boot or provision, what boot file is assigned, etc.

Unfortunately, several days after installation the modem went into “walled garden” status. This means it wasn’t recognized or considered activated (usually the case) by Comcast’s systems. It’s what you see when you buy a modem from Amazon or BestBuy and bring it home to self activate. The technician who installed our service was able to return and resolve this. When he arrived, I was already on the phone with Comcast’s Executive Relations team as their support team didn’t know the difference of gigaBIT versus gigaBYTE, let alone that it was a residential high speed internet service offered by Comcast/XFINITY. It was during this call with their Executive Resolutions team I was informed the following:

“The modem I was trying to use is incompatible with the Gigabit service and they audited/removed it from my account.”

This explains it being in walled garden. Of course, this isn’t the case, the modem is fully compatible with the service. And that modem was issued to me by a tech. A major part of this issue being able to continue for as long as it has is the non-education of Comcast agents. They haven’t had enough experience to even know what it is, let alone to troubleshoot it. It’s not your average DOCSIS 3.0 configuration. This is partly because Comcast hasn’t launched DOCSIS 3.1 everywhere, en masse.

My XFINITY Gigabit Internet Service went into walled garden again on 19th and 22nd,. I called Comcast, of course, as I was frustrated. Each time they would only tell me they are sorry, unsure of the cause, and replace the bootfile on my modem.

Exhausted by incompetence, I opened a complaint with the FCC, Florida Department of Agriculture and Consumer Services (the Florida Cable Franchise Authority) and Attorney General. Complaints regarding accounts in  my area seem to go to an office in South Florida, Fort Lauderdale/Boynton Beach area. I am experienced in working with their team and expected working with a professional from their office. Remember how wrong we were to go to that planet in Prometheus? How wrong we were to bring that microorganism back to life in the film LIFE? That’s how wrong I was in expecting decency from a Comcast employee.

What happens next may be shocking, but it’s true, it’s not exaggerated, hyperbole, or made up. 

My case(s) were assigned to an XFINITY Executive Relations rep called Vashty. In over 30 years on this Earth, I’ve never had the pleasure of working with someone less interested in a problem a customer is experiencing, or as rude and arrogant as Vashty. We should be so lucky to walk in her presence with our faces uncovered. I could tell from the beginning she thought this was user error, that I must be an idiot or not understand how cable internet works. It’s worth noting – I used to work for Comcast and have experience in how things worked at the time, and a more generalized understanding of how things work now. Cable technology doesn’t change that rapidly.  On our initial call, she said their system didn’t have any notes that I had phoned in on the 19th and 22nd to have their tech support teams fix the bootfile. Below are 2 screenshots of the call logs to Comcast from my mobile phone:

19th-768x1365
« 1 of 2 »

Prior to calling me, Vashty seemingly dispatched a technician to my home, who did not announce himself and disconnected my internet while I was working so he could perform some tests. The tech claimed he knocked, but he didn’t. After consulting with the tech who installed my service, and concluding the issue was related the old DOCSIS 3.0 modem being on my account still and the Comcast billing system possibly being confused and just putting my DOCSIS 3.1 modem in limbo, he offered to swap my modem out with their XB6 gateway, an all in one router/modem/wifi ap combo, but that isn’t for us. We have our own router and our own wifi access points, as do many other customers. Also, the range on the wireless access point feature of the XB6 is limited and would perform poorly in home due to the materials from which it is constructed.

Vashty called me back and said she believed my router was causing it. We have a fancy router for a home, I suppose, a Draytek Vigor 3900, but a router isn’t really capable of removing the bootfile from a modem and inserting a walled garden bootfile. And if it were possible, it would represent a huge security risk to the security of the Comcast IP network. The conversation was heated, after I casually mentioned I could fly to Philadelphia and wait for someone to help me in person (unlikely, but stranger things have happened), I couldn’t be more unprepared for her response:

“but you aren’t doing that now”

Her response was “but you aren’t doing that now”, something that’s stuck with me because her vocal inflection was full of mockery. She had the upper hand – the ability to help me or not. The amusing part was, she argued with me for at least 3 minutes (more like 5, really) about whether she said “but you aren’t doing that now”. It was like she was saying “you aren’t doing that now are you? I’m all you’re going to get.” I told her to cancel my services, and hung up. A few minutes later I phoned her back and rescinded the request for cancellation. as I’d probably buy my own modem and return theirs, and informed her she could close the FCC/Attorney General/Dept. Of Agriculture & Consumer Service Cases. I knew she wouldn’t be willing or capable of helping me.

I posted my experience with their executive support and details of my problem on the official Comcast Forms here hereTo date, Comcast has not responded to the thread, except to remove my “bump” post to get it noticed.

After the modem disconnected itself again on a weekend, I phoned Executive Care in Philly again, requesting a new case, this time without Vashty. I was assigned a rep called T. She suggested the modem I had from Comcast was defective and recommended I buy my own, since I can’t use a XB6 gateway. I complied and bought my own modem, the Motorola (really Zoom) MB8600 capable of DOCSIS 3.1 It was activated last Friday August 11. To be sure the Signal Levels were correct, I posted on DSLReports.com here to ask the community.

An aside: activating was a pain because their regular support kept confusing my tv and internet bundle (which includes blast) and putting the blast bootfile on the modem, not gigabit. I returned the Technicolor Modem and the Netgear router they gave me when I had service installed to Comcast in Jacksonville on Sat Aug 12. You can see the receipt below:

The names of the reps who assisted me are Elezar (Alex on his badge) and Jose.

Around midnight on August 15th, the modem went into walled garden again. I updated my DSLReports.com thread with details, images, and the like. You can see below where my Motorola Modem was in walled garden via the bootfile name. Have a look at the event log and connection status pages from the modem below:

 

eventlog-1024x650
« 1 of 2 »

Note, I’ve edited out sensitive details from this, such as the MAC address. 

On August 15, I noticed on the Comcast My Account page, the equipment list only shows the NETGEAR Router I returned to Comcast on the 12th. My own modem was removed from this list. See below screenshots:

detailsofreturnedrouter-768x1365
« 1 of 2 »

I also phoned the Corporate Escalation team voicemail on 8-15-17 at 12:05 pm and left a voicemail. Their number is 855-820-5946. I have called the executive care person i was assigned from reopening the case, T., several times since speaking with her last Thursday. T. said she was going out of town on Wednesday the 16th until the following Monday, but she didn’t take any of my calls on Monday/Tuesday 14th/15th of this week (August), or return voicemails.

I have begun recording calls as of 8/16/2017 as Comcast is fond of making statements and & not following up, and also arguing with me. Though I’m sure the recordings can’t be used for legal purposes, I can demonstrate incompetence through the recordings, and gaps in their training. Speaking of logs, I have a fairly well-functioning relationship with the people on @comcastcares (Twitter). They have little power, but are quick to reply to things and offer consistent answers.

I’ve posted on dslreports.com in the Direct XFINITY Support section and the regular public community, others are also having this issue – interestingly. There are at least 2 others posting about the same issue I had, and other users with the same problem are chiming in on existing threads.

Update 8/15/2017! I’ve requested a new escalation as of 8/15/2017 and spoke with a guy named Eddie. I was told he contacted a number of managers to make them aware of this and they were going to call me by the end of the day. ut they have not called me back yet, though I was promised a call by end of day 8-15-2017. I began a new job just before ordering this service and as I work from home, I need it to work. This ordeal has made a fairly well managed anxiety disorder much worse, and has caused untold amounts of stress on my household. I had to switch cell providers to get a more expensive plan with hotspot so I could continue to work during these outages.

Update 8-16-2017! – I did not hear from anyone, as promised, and unsurprisingly. I called the Philly number for corporate again and spoke with another Andrew who said he couldn’t find the email Eddie sent and it seemed like they were trying to dodge me. After some hold time, he came back and told me someone called “D.” was assigned to this and would call me.

No call yet (eve of 8/16/2017)

Update 8/17/2017!  Still no call from their escalations team, no tech visits, etc. My customer owned modem has reappeared in the myaccount section. See below:

They still show the Netgear router on the account. I’m not sure if this is a fluke or if was put back there in preparation for a phone call I’ve yet to receive. If I do not hear from them today by 4 or so, work permitting, I will call their corporate team back, again.

I mentioned earlier I also phoned the Corporate Escalation team voicemail on 8-15-17 at 12:05 pm and left a voicemail. Their number is 855-820-5946. I still have not received a callback from the voicemail or their corporate team, even after 2 escalation attempts. I called their corporate number again today. I spoke with Rita. She claims D called me yesterday, she did not. Below are 2 screen shots depicting the sum of yesterday’s calls to my cell phone. She would not give me D’s number. She transferred me to her voicemail where I left a message.

noinboundcallfromcomcast2-768x1365
« 1 of 2 »

Now, you may be wondering why there are no numbers in those screenshots. That’s because the calls that were placed or received are not from Comcast and are from private numbers/contacts. After this far into this process, I wouldn’t blank out Comcast’s number for any strange reason. 😉

Updates: eve of 8/17/2017! Here is another thread on dslreports.com, this user is reporting the same thing I am:. 

Since the outage, the modem was disconnected from my router. I checked it this afternoon and the modem appears to have the correct bootfile again, not sure how that happened since I didn’t speak to anyone today or yesterday in a troubleshooting capacity. The netgear router is still on my account, I have messaged @comcastcares via Twitter DM to inquire about this, as they assured me it would be removed. This is a current Speedtest. Not close to what I’m paying for, even with the 30 meg or so that’s sapped from 1000 meg due to TCP/IP overhead.

8/17/2017 – 9:49 PMRandom speed test. Terrible results on the download. My network was not in use at this time. Page loads are laggy, it feels like slow DNS Resolvers, though I’m using 8.8.8.4 and 8.8.4.4 – Google Public DNS. 

I also learned Business Class gigabit is not able to be delivered to my address. Only 250 meg, which is too expensive for the speed provided, even the SLA isn’t worth it. We are too far for Metro Ethernet and 2 gigabit fiber is not an option at this time either. We can only go back down to DOCSIS 3.0 150 meg, or cancel service and go back to the unreliable phone company.

Update 8/17/2017 11:53 pm – A XFINITY Employee on the Comcast Forums has responded to say thanks for reaching out and apologized for the delay in their response. I let him know the following:

Thank you for the reply. The agent I spoke with is no longer answering my calls and from what I understand, another agent has been assigned to assist and claims she called me yesterday and left a voicemail, I can assure you that call and voicemail never came through. If there’s anything you can do to help, that’d be great because my internet is still on the fritz here and there. The issue is definitely not resolved. Far, far from resolution.

Update 8/18/2017 9:00 pm – Friday came and went without a call from a technician or member of Comcast Corporate Escalations, Customer Support, etc.

Update 8/19 and 8/20 – No call from D. Their offices are closed on the weekend. 

Update 8/21/2017 – D. calls at 11 am, normally I would be available, but it being a meeting filled Monday, I couldn’t speak with her. The phone number she instructs me to call back is not hers, but the number of the other rep, T. Again, she won’t give me her number it seems.

That afternoon I called Comcast corporate again, i spoke with Andrew (again) who only apologized (not much he can do really) and said I would receive a call from someone by EOD. He advised if I didn’t receive a call to phone by to Corporate Escalations in the AM and ask for another escalation.

Update 8/22/2017 – No calls last night, as predicted. No calls this morning. I phoned Corporate back and had it escalated again. I was told someone would phone me by EOD. Interestingly, when the rep confirmed the call back number (something all reps had previously done), she did not read my cell. She read me a random number, at least in my area code. That would explain why I have not been receiving calls and their notes have stated they made a call attempt. The other agent, T., to whom the case was assigned before she went on vacation phones me back that afternoon. I was asked to monitor it for a few days and call T back on Friday or Monday to apprise her of any updates. She opened a Level 3 Engineering ticket for me during this time, as well.

Update 8/23 – 8/24 – Internet has been stable for a few days, speed tests look good. I cannot say without a doubt this issue is resolved, or if it was a fluke. I am still holding out for word from Engineering. Most people with the title “Engineer” are competent, so I expect something that makes sense. Although, this is Comcast we’re talking about.

Update 8/25 – I received a Private Message from the same Comcast Community Forums Moderator. He informed me my escalation has been closed because I refused to let them send a tech to investigate further. Completely untrue, at no time during this have I denied them to waste money and send a technician. Screen shot of the message is below:

 

Conclusion:

In September, Hurricane Irma swept through Florida on a rampage, leaving devastation and destruction in it’s wake. For nearly 3 days we were without cable/internet. Of course, this isn’t a complaint, there were many who were without much more, for much longer. Once Comcast repaired the lines and service was restored, things worked well. However, it had been some time since I spoke with  the rep in Executive Care. For nearly 2 weeks I waited for a call, I knew they were in South Florida and were still reeling from the effects of Irma, so I was trying to be patient. From a service perspective, we had begun noticing artifacts in video from the cable boxes and a exponential increase in uncorrectables from the modem.

Oddly enough, while I was on my way to Orlando for a weekend get away, I received a call from Comcast, a supervisor. She explained she received a complaint some weeks ago about an employee who demonstrated unprofessional behavior on the phone with a customer and wanted to contact to see if she could assist with my on going issue. How very strange. She confirms it was Vashty, the representative who earlier argued with me about whether she said something completely trivial (or not) instead of trying to listen to reason and logic. The Supervisor has reviewed the case with the individual who I was later assigned, T, and is happy to help. Filling her in on the details of the last few weeks, she comments she will get a tech crew out there and apologizes repeatedly for the hassle and inappropriate behavior from Vashty.

I later learned Vashty was indeed terminated for her actions/inaction. I also learned from the supervisor, the other individual at Comcast Exec – T, with whom I was working had notated she tried, unsuccessfully, to contact me. As I keep meticulous phone records and had already begun recording calls to/from Comcast, I could prove she was falsifying records. Within a few days, a technician from the Comcast Maintenance Crew arrived and over the course of 2 days investigation discovered a broken tap, a damaged ped and node, some aerial filters and a broken run with reflections, which had to be dug up by the street and redone. Another technician came out and replaced the input on the side of our home, tightened up a few cables in the house, and redid the wiring in our wiring closet with newer fittings.

The maintenance was successful, and we immediately noticed a near perfect signal report from the modem, consistent speeds, and no bootfile issue. A miracle! I let it run for about 1.5 weeks before letting the supervisor know I was ready to close out the ticket. They offered me a $400 credit, which is equal to 4 months of the Gigabit service, essentially.

What have we learned?

The important take away here is, what is going on with Comcast’s management of customer reported issues on newly launched products? The Gigabit services in my area were only made available a short time before I had it installed. The technician claimed I was on the only one in the county who had it when they installed my service. Surely, Comcast would take note of newly installed customers reporting issues with a newly available product and not let issues like mine get so far.

In the end, the fix was easy, Comcast just sat on their hands for a while, lied, argued, falsified records to avoid speaking to me, and blamed the third-party every time they could, costing them more than it would’ve to fix investigate and fix the problem, initially. A stupid mistakes!

This won’t be the last battle I’ll have with Comcast, I assure you. But each battle yields much needed experience points.